UVSurfaceOps Class
Support methods to act on surfaces with 0..1 uv fractional parameterization
Methods
Name | Description | |
---|---|---|
createLinestringOnUVLine(surface: UVSurface, u0: number, v0: number, u1: number, v1: number, numEdge: number, saveUV: booleanfalse, saveFraction: booleanfalse): LineString3d Static | * evaluate numEdge+1 points at surface uv parameters interpolated between (u0,v0) and (u1,v1) |
|
sampledRangeOfOffsetEllipsoidPatch(patch: EllipsoidPatch, offsetDistance: number, options?: StrokeOptions): Range3d Static | Return the range of sampled points at specified offset from the surface. | |
sampledRangeOfOffsetPatch(patch: UVSurface, offsetDistance: number, numU: number, numV: number): Range3d Static | Return the range of sampled points at specified offset from the surface. |
Defined in
- geometry3d/UVSurfaceOps.ts Line 21
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.