appendPolygonClip Method
Implement appendPolygonClip, as defined in interface PolygonClipper.
appendPolygonClip(xyz: IndexedXYZCollection, insideFragments: GrowableXYZArray[], outsideFragments: GrowableXYZArray[], arrayCache: ): void
Parameter | Type | Description |
---|---|---|
xyz | IndexedXYZCollection | convex polygon. This is not changed. |
insideFragments | GrowableXYZArray[] | Array to receive "inside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
outsideFragments | GrowableXYZArray[] | Array to receive "outside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
arrayCache | cache for reusable GrowableXYZArray. |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.