multiplyInversePoint3dArrayInPlace Method
Multiply each point in the array by the inverse of this
Transform in place.
- For a transform
T = [M o]
the inverse transformT' = [M' -M'o]
exists if and only ifM
has an inverseM'
. Indeed, for any pointp
, we haveT'Tp = T'(Mp + o) = M'(Mp + o) - M'o = M'Mp + M'o - M'o = p.
- Returns
true
if thematrix
part if this Transform is invertible andfalse
if singular.
multiplyInversePoint3dArrayInPlace(points: Point3d[]): boolean
Parameter | Type | Description |
---|---|---|
points | Point3d[] |
Returns - boolean
Defined in
- geometry3d/Transform.ts Line 605
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.