clipBy01FunctionValuesPositive Method
On input, this
is an interval of a line. On output, the interval has been clipped to positive parts of a linear function
- f0 and f1 are values at parameter values 0 and 1 (which are in general NOT x0 and x1)
- From that determine where the segment crosses function value 0.
- The segment contains some interval in the same parameter space.
- Clip the segment to the positive part of the space.
- Return true (and modify the segment) if any of the segment remains.
- Return false (but without modifying the segment) if the active part is entirely out.
clipBy01FunctionValuesPositive(f0: number, f1: number): boolean
Parameter | Type | Description |
---|---|---|
f0 | number | |
f1 | number |
Returns - boolean
Defined in
- geometry3d/Segment1d.ts Line 125
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.