tryNormalizeInPlaceWithAreaWeight Method
Normalize the ray direction in place.
- If parameter
a
is clearly nonzero and the direction vector can be normalized,- Save the parameter
a
as the optionala
member of the ray. - Normalize the ray's direction vector.
- Save the parameter
- If parameter
a
is nearly zero,- Set the
a
member to zero. - Set the ray's direction vector to zero.
- Set the
tryNormalizeInPlaceWithAreaWeight(a: number): boolean
@returns true
if a
is nonzero and normalization was successful. Otherwise, return false
.
Parameter | Type | Description |
---|---|---|
a | number | value to be saved (e.g,. area). |
Returns - boolean
true
if a
is nonzero and normalization was successful. Otherwise, return false
.
Defined in
- geometry3d/Ray3d.ts Line 321
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.