intersectionWithRange3d Method

Find the intersection of the line defined by the ray with a Range3d.

  • Return the range of parameters (on the ray) which are "inside" the range.
  • Note that a range is always returned; if there is no intersection it is indicated by the test result.isNull.

intersectionWithRange3d(range: Range3d, result?: Range1d): Range1d

Parameter Type Description
range Range3d  
result Range1d  

Returns - Range1d

Defined in

Last Updated: 14 November, 2024