createOriginAndTarget MethodStatic
Create from origin
and target
points.
createOriginAndTarget(origin: Point2d, target: Point2d, result?: Ray2d): Ray2d
Parameter | Type | Description |
---|---|---|
origin | Point2d | ray origin, cloned |
target | Point2d | end of ray direction vector. The direction vector is target - origin . |
result | Ray2d | optional pre-allocated object to return |
Returns - Ray2d
Defined in
- geometry3d/Ray2d.ts Line 38
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.