compressSmallTriangles MethodStatic
Return a simplified subset of given points, omitting points of the triangle with adjacent points is small.
- This is a local search, with a single pass over the data.
compressSmallTriangles(source: Point3d[], maxTriangleArea: number): Point3d[]
Parameter | Type | Description |
---|---|---|
source | Point3d[] | input points |
maxTriangleArea | number |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 66
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.