compressShortEdges MethodStatic
Return a simplified subset of given points, omitting points if very close to their neighbors.
- This is a local search, with a single pass over the data.
compressShortEdges(source: IndexedXYZCollection | Point3d[], maxEdgeLength: number): Point3d[]
Parameter | Type | Description |
---|---|---|
source | IndexedXYZCollection | Point3d[] | input points |
maxEdgeLength | number |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 55
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.