compressDanglers MethodStatic
Return a simplified subset of given points, omitting points on "danglers" that depart and return on a single path.
compressDanglers(source: Point3d[], closed: booleanfalse, tolerance: numberGeometry.smallMetricDistance): Point3d[]
Parameter | Type | Description |
---|---|---|
source | Point3d[] | input points |
closed | boolean | if true, an edge returning to point 0 is implied even if final point does not match. |
tolerance | number | tolerance for near-zero distance. |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 146
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.