compressByPerpendicularDistance MethodStatic
Return a simplified subset of given points, omitting points if close to the edge between neighboring points before and after
- This is a local search, with a single pass over the data for each pass.
compressByPerpendicularDistance(source: Point3d[], maxDistance: number, numPass: number2): Point3d[]
Parameter | Type | Description |
---|---|---|
source | Point3d[] | input points |
maxDistance | number | omit points if this close to edge between points before and after |
numPass | number | max number of times to run the filter. numPass=2 is observed to behave well. |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 80
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.