compressByChordError MethodStatic
Return a simplified subset of given points.
- Points are removed by the Douglas-Puecker algorithm, viz https://en.wikipedia.org/wiki/Ramer–Douglas–Peucker_algorithm
- This is a global search, with multiple passes over the data.
compressByChordError(source: Point3d[], chordTolerance: number): Point3d[]
Parameter | Type | Description |
---|---|---|
source | Point3d[] | |
chordTolerance | number |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 46
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.