unitNormal MethodStatic
Return a unit normal to the plane of the polygon.
unitNormal(points: IndexedXYZCollection, result: Vector3d): boolean
@returns true if and only if result has unit length
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | array of points around the polygon. |
result | Vector3d | caller-allocated result vector. |
Returns - boolean
true if and only if result has unit length
Defined in
- geometry3d/PolygonOps.ts Line 618
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.