sortOuterAndHoleLoopsXY MethodStatic
Reverse and reorder loops in the xy-plane for consistency and containment.
sortOuterAndHoleLoopsXY(loops: IndexedReadWriteXYZCollection[]): IndexedReadWriteXYZCollection[][]
@returns array of arrays of polygons that capture the input pointers. In each first level array:
- The first polygon is an outer loop, oriented counterclockwise.
- Any subsequent polygons are holes of the outer loop, oriented clockwise.
Parameter | Type | Description |
---|---|---|
loops | IndexedReadWriteXYZCollection[] | multiple polygons in any order and orientation, z-coordinates ignored |
Returns - IndexedReadWriteXYZCollection[][]
array of arrays of polygons that capture the input pointers. In each first level array:
- The first polygon is an outer loop, oriented counterclockwise.
- Any subsequent polygons are holes of the outer loop, oriented clockwise.
Defined in
- geometry3d/PolygonOps.ts Line 868
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.