forceClosure MethodStatic
Force the polygon to be closed.
- If first and last points are not within tolerance, push copy of first point
- If first and last points are within tolerance, set last point equal to first
forceClosure(polygon: Point3d[] | GrowableXYZArray, tolerance: numberGeometry.smallMetricDistance): void
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | GrowableXYZArray | input polygon |
tolerance | number | closure distance tolerance |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 1288
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.