addForwardLeft Method
Starting at this point, move along vector
by tangentFraction
of its length, and then
by leftFraction
of its length along the left perpendicular.
addForwardLeft(tangentFraction: number, leftFraction: number, vector: Vector2d, result?: Point2d): Point2d
Parameter | Type | Description |
---|---|---|
tangentFraction | number | distance to move along vector , as a fraction of its length |
leftFraction | number | distance to move perpendicular to vector , as a fraction of its length |
vector | Vector2d | the other vector |
result | Point2d |
Returns - Point2d
Defined in
- geometry3d/Point2dVector2d.ts Line 227
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.