getUnitNormal Method
Return the unit normal for the plane.
- The abstract base class implementation assembles the normal from normalX, normalY, normalZ calls.
- Derived classes should (but are not required to) override for maximum efficiency if the separate normal calls cause repeated normalization.
getUnitNormal(result?: Vector3d): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
result | Vector3d |
Returns - undefined | Vector3d
Defined in
- geometry3d/Plane3d.ts Line 109
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.