toQuaternion Method
Create this
matrix to a quaternion.
Note: This calculation requires this
matrix to have unit length rows and columns.
WARNING: There is frequent confusion over whether a "from quaternion" matrix is organized by
rows or columns. If you find that the matrix seems to rotate by the opposite angle, transpose it.
Some math details can be found at http://marc-b-reynolds.github.io/quaternions/2017/08/08/QuatRotMatrix.html
toQuaternion(): Point4d
Returns - Point4d
Defined in
- geometry3d/Matrix3d.ts Line 2892
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.