setColumns Method
Set all columns of the matrix. Any undefined vector is zeros.
setColumns(vectorX: Vector3d, vectorY: Vector3d, vectorZ?: Vector3d): void
Parameter | Type | Description |
---|---|---|
vectorX | Vector3d | values for column 0 |
vectorY | Vector3d | values for column 1 |
vectorZ | Vector3d | optional values for column 2 (it's optional in case column 2 is 000, which is a projection onto the xy-plane) |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 1556
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.