normalizeRowsInPlace Method
Normalize each row in place.
normalizeRowsInPlace(originalRowMagnitudes?: Vector3d): boolean
@returns return true if all rows have non-zero lengths. Otherwise, return false.
- If false is returned, the magnitudes are stored in the
originalRowMagnitudes
vector but no rows are altered.
Parameter | Type | Description |
---|---|---|
originalRowMagnitudes | Vector3d | optional vector to store original row magnitudes. |
Returns - boolean
return true if all rows have non-zero lengths. Otherwise, return false.
- If false is returned, the magnitudes are stored in the
originalRowMagnitudes
vector but no rows are altered.
Defined in
- geometry3d/Matrix3d.ts Line 2364
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.