normalizeColumnsInPlace Method
Normalize each column in place.
normalizeColumnsInPlace(originalColumnMagnitudes?: Vector3d): boolean
@returns return true if all columns have non-zero lengths. Otherwise, return false.
- If false is returned, the magnitudes are stored in the
originalColumnMagnitudes
vector but no columns are altered.
Parameter | Type | Description |
---|---|---|
originalColumnMagnitudes | Vector3d | optional vector to store original column magnitudes. |
Returns - boolean
return true if all columns have non-zero lengths. Otherwise, return false.
- If false is returned, the magnitudes are stored in the
originalColumnMagnitudes
vector but no columns are altered.
Defined in
- geometry3d/Matrix3d.ts Line 2346
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.