multiplyInverseXYZW Method
Multiply matrixInverse * [x,y,z]
and return result as a Point4d
with the given weight as the last coordinate.
- Equivalent to solving
matrix * result = [x,y,z]
for an unknownresult
. - Result is
undefined
if the matrix is singular (e.g. has parallel columns or a zero magnitude column)
multiplyInverseXYZW(x: number, y: number, z: number, w: number, result?: Point4d): undefined | Point4d
@returns result as a Point4d with the same weight.
Parameter | Type | Description |
---|---|---|
x | number | |
y | number | |
z | number | |
w | number | |
result | Point4d |
Returns - undefined | Point4d
result as a Point4d with the same weight.
Defined in
- geometry3d/Matrix3d.ts Line 2036
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.