multiplyInverseXYZAsVector3d Method
Multiply matrixInverse * [x,y,z]
.
- This is equivalent to solving
matrix * result = [x,y,z]
for an unknownresult
. - Result is
undefined
if the matrix is singular (e.g. has parallel columns or a zero magnitude column)
multiplyInverseXYZAsVector3d(x: number, y: number, z: number, result?: Vector3d): undefined | Vector3d
@returns result as a Vector3d or undefined (if the matrix is singular).
Parameter | Type | Description |
---|---|---|
x | number | |
y | number | |
z | number | |
result | Vector3d |
Returns - undefined | Vector3d
result as a Vector3d or undefined (if the matrix is singular).
Defined in
- geometry3d/Matrix3d.ts Line 2018
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.