getAxisAndAngleOfRotation Method
Compute the (unit vector) axis and angle for the rotation generated by this
Matrix3d.
- Math details can be found at docs/learning/geometry/Angle.md
getAxisAndAngleOfRotation(): { angle: Angle, axis: Vector3d, ok: boolean }
@returns Returns axis and angle of rotation with result.ok === true when the conversion succeeded.
Returns - { angle: Angle, axis: Vector3d, ok: boolean }
Returns axis and angle of rotation with result.ok === true when the conversion succeeded.
Defined in
- geometry3d/Matrix3d.ts Line 1168
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.