createPerpendicularVectorFavorXYPlane MethodStatic
Return a vector that is perpendicular to the input vectorA
.
- Among the infinite number of perpendiculars possible, this method favors having one in the xy plane.
- Hence, when
vectorA
is close to the Z axis, the returned vector isvectorA cross -unitY
but whenvectorA
is NOT close to the Z axis, the returned vector isunitZ cross vectorA
.
createPerpendicularVectorFavorXYPlane(vectorA: Vector3d, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | |
result | Vector3d |
Returns - Vector3d
Defined in
- geometry3d/Matrix3d.ts Line 653
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.