createPerpendicularVectorFavorPlaneContainingZ MethodStatic
Return a vector that is perpendicular to the input vectorA
.
- Among the infinite number of perpendiculars possible, this method favors having one near the plane
containing Z.
That is achieved by cross product of
this
vector with the result of createPerpendicularVectorFavorXYPlane.
createPerpendicularVectorFavorPlaneContainingZ(vectorA: Vector3d, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | |
result | Vector3d |
Returns - Vector3d
Defined in
- geometry3d/Matrix3d.ts Line 670
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.