intersectRangeConvexPolygonInPlace MethodStatic
Return the intersection of the plane with a range cube.
intersectRangeConvexPolygonInPlace(range: Range3d, xyz: GrowableXYZArray): undefined | GrowableXYZArray
@returns reference to xyz if the polygon still has points; undefined if all points are clipped away.
Parameter | Type | Description |
---|---|---|
range | Range3d | |
xyz | GrowableXYZArray |
Returns - undefined | GrowableXYZArray
reference to xyz if the polygon still has points; undefined if all points are clipped away.
Defined in
- geometry3d/PolygonOps.ts Line 1588
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.