worldToLocal Method
- Convert a world point to point within the underlying mapped sphere space.
- In the sphere space, an xyz (vector from origin) with magnitude equal to 1 is ON the sphere (hence its world image is ON the ellipsoid)
- In the sphere space, an xyz (vector from origin) with magnitude less than 1 is INSIDE the sphere (hence its world image is INSIDE the ellipsoid)
- In the sphere space, an xyz (vector from origin) with magnitude greater than 1 is OUTSIDE the sphere (hence its world image is OUTSIDE the ellipsoid)
- This is undefined in the highly unusual case that the ellipsoid frame is singular.
worldToLocal(worldPoint: Readonly<WritableXYAndZ>, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
worldPoint | Readonly<WritableXYAndZ> | |
result | Point3d |
Returns - undefined | Point3d
Defined in
- geometry3d/Ellipsoid.ts Line 204
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.