radiansToPointAndDerivatives Method

Evaluate a point and derivatives with respect to angle on the ellipsoid at angles give in radians.

  • "u direction" vector of the returned plane is derivative with respect to longitude.
  • "v direction" vector fo the returned plane is derivative with respect ot latitude.

radiansToPointAndDerivatives(thetaRadians: number, phiRadians: number, applyCosPhiFactor: booleantrue, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors

Parameter Type Description
thetaRadians number longitude, in radians
phiRadians number latitude, in radians
applyCosPhiFactor boolean selector for handling of theta (around equator derivative)
* if true, compute the properly scaled derivative, which goes to zero at the poles.
* If false, omit he cos(phi) factor on the derivative wrt theta. This ensures it is always nonzero and can be safely used in cross product for surface normal.
result Plane3dByOriginAndVectors optional plane result

Returns - Plane3dByOriginAndVectors

Defined in

Last Updated: 28 October, 2024