radiansPairToGreatArc Method

  • For a given pair of points on an ellipsoid, construct an arc (possibly elliptical) which
    • passes through both points
    • is completely within the ellipsoid surface
    • has its centerEvaluate a point on the ellipsoid at angles give in radians.
  • If the ellipsoid is a sphere, this is the shortest great-circle arc between the two points.
  • If the ellipsoid is not a sphere, this is close to but not precisely the shortest path.

radiansPairToGreatArc(thetaARadians: number, phiARadians: number, thetaBRadians: number, phiBRadians: number, result?: Arc3d): undefined | Arc3d

Parameter Type Description
thetaARadians number longitude, in radians, for pointA
phiARadians number latitude, in radians, for pointA
thetaBRadians number longitude, in radians, for pointB
phiBRadians number latitude, in radians, for pointB
result Arc3d optional preallocated result

Returns - undefined | Arc3d

Defined in

Last Updated: 28 October, 2024