radiansPairToEquatorialEllipsoid Method
- For a given pair of points on an ellipsoid, construct another ellipsoid
- touches the same xyz points in space
- has transformation modified so that the original two points are on the equator.
- Note that except for true sphere inputs, the result axes can be both non-perpendicular axes and of different lengths.
radiansPairToEquatorialEllipsoid(thetaARadians: number, phiARadians: number, thetaBRadians: number, phiBRadians: number, result?: Ellipsoid): undefined | Ellipsoid
Parameter | Type | Description |
---|---|---|
thetaARadians | number | longitude, in radians, for pointA |
phiARadians | number | latitude, in radians, for pointA |
thetaBRadians | number | longitude, in radians, for pointB |
phiBRadians | number | latitude, in radians, for pointB |
result | Ellipsoid | optional preallocated result |
Returns - undefined | Ellipsoid
Defined in
- geometry3d/Ellipsoid.ts Line 472
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.