projectPointToSurface Method
Find the closest point of the (patch of the) ellipsoid.
- In general there are multiple points where a space point projects onto an ellipse.
- This searches for only one point, using heuristics which are reliable for points close to the surface but not for points distant from highly skewed ellipsoid
projectPointToSurface(spacePoint: Point3d): undefined | LongitudeLatitudeNumber
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d |
Returns - undefined | LongitudeLatitudeNumber
Defined in
- geometry3d/Ellipsoid.ts Line 243
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.