reloadSweptPolygon Method
- Define new planes in this ConvexClipPlaneSet so it clips to the inside of a polygon.
- always create planes for the swept edges of the polygon
- optionally (with nonzero sideSelect) create a cap plane using the polygon normal.
reloadSweptPolygon(points: Point3d[], sweepDirection: Vector3d, sideSelect: number): number
Parameter | Type | Description |
---|---|---|
points | Point3d[] | Points of a bounding polygon |
sweepDirection | Vector3d | direction to sweep. |
sideSelect | number | 0 to have no cap polygon, 1 if the sweep vector side is in, -1 if sweep vector side is out. |
Returns - number
Defined in
- clipping/ConvexClipPlaneSet.ts Line 649
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.