createXYPolyLine MethodStatic
Create a convex set containing a half space for each edge between points of a polyline.
- Caller is responsible for assuring the polyline is convex.
createXYPolyLine(points: Point3d[], interior: boolean[], leftIsInside: boolean, result?: ConvexClipPlaneSet): ConvexClipPlaneSet
Parameter | Type | Description |
---|---|---|
points | Point3d[] | array of points. Only xy parts are considered. |
interior | boolean[] | array whose boolean value is used as both the interior and invisible bits of the plane for thesucceeding segment. If this array is not provided, both are false. |
leftIsInside | boolean | if true, the interior is "to the left" of the segments. If false, interior is "to the right". |
result | ConvexClipPlaneSet |
Returns - ConvexClipPlaneSet
Defined in
- clipping/ConvexClipPlaneSet.ts Line 188
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.