createRange3dPlanes MethodStatic
Create new convex set using selected planes of a Range3d.
createRange3dPlanes(range: Range3d, lowX: booleantrue, highX: booleantrue, lowY: booleantrue, highY: booleantrue, lowZ: booleantrue, highZ: booleantrue): ConvexClipPlaneSet
Parameter | Type | Description |
---|---|---|
range | Range3d | range with coordinates |
lowX | boolean | true to clip at the low x plane |
highX | boolean | true to clip at the high x plane |
lowY | boolean | true to clip at the low y plane |
highY | boolean | true to clip at the high z plane |
lowZ | boolean | true to clip at the low z plane |
highZ | boolean | true to clip at the high z plane |
Returns - ConvexClipPlaneSet
Defined in
- clipping/ConvexClipPlaneSet.ts Line 119
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.