clipUnboundedSegment Method
Find the parts of the (unbounded) line segment (if any) that is within the convex clip volume.
clipUnboundedSegment(pointA: Point3d, pointB: Point3d, announce?: AnnounceNumberNumber): boolean
@returns true if a segment was announced, false if entirely outside.
Parameter | Type | Description |
---|---|---|
pointA | Point3d | segment start (fraction 0) |
pointB | Point3d | segment end (fraction 1) |
announce | AnnounceNumberNumber | function to be called to announce a fraction interval that is within the convex clip volume. |
Returns - boolean
true if a segment was announced, false if entirely outside.
Defined in
- clipping/ConvexClipPlaneSet.ts Line 444
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.