clipInsidePushOutside Method
Clip a convex polygon to (a single) inside part and (possibly many) outside parts.
clipInsidePushOutside(xyz: IndexedXYZCollection, outsideFragments: GrowableXYZArray[], arrayCache: ): undefined | GrowableXYZArray
@returns the surviving inside part (if any)
Parameter | Type | Description |
---|---|---|
xyz | IndexedXYZCollection | input polygon. |
outsideFragments | GrowableXYZArray[] | an array to receive (via push, with no preliminary clear) outside fragments |
arrayCache | cache for work arrays. |
Returns - undefined | GrowableXYZArray
the surviving inside part (if any)
Defined in
- clipping/ConvexClipPlaneSet.ts Line 477
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.