classifyPointContainment Method
Returns 1, 2, or 3 based on whether point array is strongly inside, ambiguous, or strongly outside respectively.
- This has a peculiar expected use case as a very fast pre-filter for more precise clipping.
- The expected point set is for a polygon.
- Hence any clipping will eventually have to consider the lines between the points.
- This method looks for the special case of a single clip plane that has all the points outside.
- In this case the whole polygon must be outside.
- Note that this does not detect a polygon that is outside but "crosses a corner" -- it is mixed with respect to multiple planes.
classifyPointContainment(points: Point3d[], onIsOutside: boolean): ClipPlaneContainment
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
onIsOutside | boolean |
Returns - ClipPlaneContainment
Defined in
- clipping/ConvexClipPlaneSet.ts Line 528
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.