announceClippedSegmentIntervals Method
Find the parts of the line segment (if any) that is within the convex clip volume.
- The line segment is defined by
pointA
andpointB
. - The input fractional interval from
fraction0
tofraction1
(increasing) is the active part to consider. - To clip to the usual bounded line segment, start with fractions (0,1). If the clip volume is unbounded, the line interval may also be unbounded.
- An unbounded line portion will have fraction coordinates positive or negative
Number.MAX_VALUE
.
announceClippedSegmentIntervals(f0: number, f1: number, pointA: Point3d, pointB: Point3d, announce?: AnnounceNumberNumber): boolean
@returns true if a segment was announced, false if entirely outside.
Parameter | Type | Description |
---|---|---|
f0 | number | fraction that is the initial lower fraction of the active interval (e.g., 0.0 for bounded segment). |
f1 | number | fraction that is the initial upper fraction of the active interval (e.g., 1.0 for bounded segment). |
pointA | Point3d | segment start (fraction 0) |
pointB | Point3d | segment end (fraction 1) |
announce | AnnounceNumberNumber | function to be called to announce a fraction interval that is within the convex clip volume. |
Returns - boolean
true if a segment was announced, false if entirely outside.
Defined in
- clipping/ConvexClipPlaneSet.ts Line 386
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.