toCompactString Method
Serializes this ClipVector to a compact string representation appropriate for transmission as part of a URL. Chiefly used for requesting Tiles with section cut facets. UnionOfConvexClipPlaneSets is obtained for each ClipPrimitive. The encoding is as follows: ClipVector: ClipPrimitive[] _ ClipPrimitive: invisible: 0|1 ConvexClipPlaneSet[] _ ConvexClipPlaneSet: ClipPlane[] _ ClipPlane: flags: 0|1|2|3, where 1=invisible and 2=interior inwardNormal: Number[3] distance: Number Number: number _
toCompactString(): string
Returns - string
Defined in
- clipping/ClipVector.ts Line 423
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.