classifyPointContainment Method
Determines whether the given points fall inside or outside this set of ClipShapes. If any set is defined by masking planes, checks the mask planes only, provided that ignoreMasks is false. Otherwise, checks the _clipPlanes member.
classifyPointContainment(points: Point3d[], ignoreMasks: booleanfalse): ClipPlaneContainment
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
ignoreMasks | boolean |
Returns - ClipPlaneContainment
Defined in
- clipping/ClipVector.ts Line 322
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.