doesConvexClipPlaneSetIntersectRange MethodStatic
Emit point loops for intersection of a convex set with a range.
- return zero length array for (a) null range or (b) no intersections
doesConvexClipPlaneSetIntersectRange(convexSet: ConvexClipPlaneSet, range: Range3d, includeConvexSetFaces: booleantrue, includeRangeFaces: booleantrue, ignoreInvisiblePlanes: booleanfalse): boolean
Parameter | Type | Description |
---|---|---|
convexSet | ConvexClipPlaneSet | |
range | Range3d | range to intersect |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - boolean
Defined in
- clipping/ClipUtils.ts Line 593
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.