clipPolygonToClipShapeReturnGrowableXYZArrays MethodStatic
Clip a polygon down to regions defined by each shape of a ClipShape.
clipPolygonToClipShapeReturnGrowableXYZArrays(polygon: Point3d[], clipShape: ClipPrimitive): GrowableXYZArray[]
@returns An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | |
clipShape | ClipPrimitive |
Returns - GrowableXYZArray[]
An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Defined in
- clipping/ClipUtils.ts Line 318
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.