createOriginAndVectors MethodStatic

Create a clip plane

createOriginAndVectors(origin: Point3d, vectorA: Vector3d, vectorB: Vector3d, invisible: booleanfalse, interior: booleanfalse, result?: ClipPlane): undefined | ClipPlane

@returns undefined if the vectors are not independent.

  • The stored inward normal is vectorB.crossProduct(vectorA).
  • That is, the vectors are considered as a right-handed pair when viewed from the outside.
Parameter Type Description
origin Point3d any point on the plane.
vectorA Vector3d any vector in the plane
vectorB Vector3d any vector in the plane
invisible boolean  
interior boolean  
result ClipPlane  

Returns - undefined | ClipPlane

undefined if the vectors are not independent.

  • The stored inward normal is vectorB.crossProduct(vectorA).
  • That is, the vectors are considered as a right-handed pair when viewed from the outside.

Defined in

Last Updated: 28 October, 2024