createNormalAndPointXYZXYZ MethodStatic
Create a ClipPlane
- "normal" (normalX, normalY, normalZ) is the inward normal of the plane.
- "point" (originX,originY,originZ) is any point of the plane.
- The stored distance for the plane is the dot product of the point with the normal (i.e. treat the point's xyz as a vector from the origin.)
createNormalAndPointXYZXYZ(normalX: number, normalY: number, normalZ: number, originX: number, originY: number, originZ: number, invisible: booleanfalse, interior: booleanfalse, result?: ClipPlane): undefined | ClipPlane
Parameter | Type | Description |
---|---|---|
normalX | number | |
normalY | number | |
normalZ | number | |
originX | number | |
originY | number | |
originZ | number | |
invisible | boolean | |
interior | boolean | |
result | ClipPlane |
Returns - undefined | ClipPlane
Defined in
- clipping/ClipPlane.ts Line 190
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.