createNormalAndPoint MethodStatic
Create a ClipPlane
- "normal" is the inward normal of the plane (it is internally normalized).
- "point" is any point of the plane.
- The stored distance for the plane is the dot product of the point with the normal (i.e. treat the point's xyz as a vector from the origin.)
createNormalAndPoint(normal: Vector3d, point: Point3d, invisible: booleanfalse, interior: booleanfalse, result?: ClipPlane): undefined | ClipPlane
Parameter | Type | Description |
---|---|---|
normal | Vector3d | |
point | Point3d | |
invisible | boolean | |
interior | boolean | |
result | ClipPlane |
Returns - undefined | ClipPlane
Defined in
- clipping/ClipPlane.ts Line 147
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.