createEdgeAndUpVector MethodStatic
Create a plane defined by two points, an up vector, and a tilt angle relative to the up vector.
createEdgeAndUpVector(point0: Point3d, point1: Point3d, upVector: Vector3d, tiltAngle?: Angle, result?: ClipPlane): undefined | ClipPlane
Parameter | Type | Description |
---|---|---|
point0 | Point3d | start point of the edge |
point1 | Point3d | end point of the edge |
upVector | Vector3d | vector perpendicular to the plane |
tiltAngle | Angle | angle to tilt the plane around the edge in the direction of the up vector. |
result | ClipPlane | optional preallocated plane |
Returns - undefined | ClipPlane
Defined in
- clipping/ClipPlane.ts Line 263
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.