clipConvexPolygonInPlace Method
Clip a polygon to the inside or outside of the plane.
- Results with 2 or fewer points are ignored.
- Other than ensuring capacity in the arrays, there are no object allocations during execution of this function.
clipConvexPolygonInPlace(xyz: GrowableXYZArray, work: GrowableXYZArray, inside: booleantrue, tolerance: numberGeometry.smallMetricDistance): number
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input points. |
work | GrowableXYZArray | work buffer |
inside | boolean | |
tolerance | number | tolerance for "on plane" decision. |
Returns - number
Defined in
- clipping/ClipPlane.ts Line 501
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.