normal Method
Return the unit normal of the triangle.
normal(result?: Vector3d): undefined | Vector3d
@returns unit normal, or undefined if cross product length is too small.
Parameter | Type | Description |
---|---|---|
result | Vector3d | optional pre-allocated vector to fill and return. |
Returns - undefined | Vector3d
unit normal, or undefined if cross product length is too small.
Defined in
- geometry3d/BarycentricTriangle.ts Line 253
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.