isInsideTriangle MethodStatic
Examine a point's barycentric coordinates to determine if it lies inside the triangle but not on an edge/vertex.
- No parametric tolerance is used.
- It is assumed b0 + b1 + b2 = 1.
isInsideTriangle(b0: number, b1: number, b2: number): boolean
@returns whether the point with barycentric coordinates is strictly inside the triangle.
Parameter | Type | Description |
---|---|---|
b0 | number | |
b1 | number | |
b2 | number |
Returns - boolean
whether the point with barycentric coordinates is strictly inside the triangle.
Defined in
- geometry3d/BarycentricTriangle.ts Line 307
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.